rom_fla_rev.spn not functioning

Software questions and issues with the FV-1

Moderator: frank

kypo
Posts: 17
Joined: Thu Feb 16, 2017 1:49 am
Location: Slovakia

rom_fla_rev.spn not functioning

Post by kypo » Thu Apr 06, 2017 3:55 am

rom_fla_rev.spn from Free DSP programs not functionin - no sweep.
What's wrong?

kypo
Posts: 17
Joined: Thu Feb 16, 2017 1:49 am
Location: Slovakia

Post by kypo » Wed Apr 12, 2017 4:41 am

Nobody knows what is bad there?

kypo
Posts: 17
Joined: Thu Feb 16, 2017 1:49 am
Location: Slovakia

Post by kypo » Fri Apr 28, 2017 12:26 am

Nobody? Frank,please, can you look at it?

frank
Posts: 991
Joined: Wed Oct 19, 2005 12:26 pm
Contact:

Post by frank » Fri Apr 28, 2017 4:38 pm

Downloaded from site, loaded into my dev board and it works fine.
Frank Thomson
Experimental Noize

kypo
Posts: 17
Joined: Thu Feb 16, 2017 1:49 am
Location: Slovakia

Post by kypo » Sat Apr 29, 2017 4:12 am

It is mysterious. I make it again just now: download from site, assembly in SpinAsm, programming in PonyProg to 24LC32 and doesn't work. In two boards. Reverb is working but flanger not, no sweep. Other progs working OK.

frank
Posts: 991
Joined: Wed Oct 19, 2005 12:26 pm
Contact:

Post by frank » Sat Apr 29, 2017 10:50 am

All I can suggest then is you check your board and make sure the POTs are working properly.
Frank Thomson
Experimental Noize

ice-nine
Posts: 125
Joined: Thu May 24, 2012 9:03 am
Contact:

Post by ice-nine » Sat Apr 29, 2017 12:03 pm

I have just put this into a pedal and it is working as it should regarding how it is coded, prehaps it would be of benefit if you could elaborate on what it isn't doing that you are expecting it to do.
www.stanleyfx.co.uk
"It's fairly straight forward, if you want to start it press start, you can work out the rest of the controls yourself."

kypo
Posts: 17
Joined: Thu Feb 16, 2017 1:49 am
Location: Slovakia

Post by kypo » Sun Apr 30, 2017 12:04 am

I test it on two boards. Others progs are working there, all pots working. On flanger (rom_fla_rev.spn downloaded from site)) working Pot0 (Reverb level) also Pot2 (Efect level) but Pot1 not working , flanger is not sweeping I think LFO not working. Internal Flanger works fine.

Digital Larry
Posts: 279
Joined: Mon Nov 12, 2012 12:12 pm
Contact:

Post by Digital Larry » Sun Apr 30, 2017 8:58 am

I tried it on my Erica Synths Black Hole and it works fine. I hadn't looked too closely at this one before, but the triangle waveform is generated "in software" rather than using a built in ramp. It's really baffling that it doesn't work for you.

DL

========================================

;--------------------------------------------------------
; flange rate from pot 1
; as adder value to ramp
; gen, filtered at 0.3Hz:
;--------------------------------------------------------
rdax pot1, 1.0 ;read pot1
mulx pot1 ;square value, range = 0 to 1
sof 0.05, 0.005 ;scale to range of 0.005 to 0.55
sof .001, 0 ;scale further to 0.00005 to 0.0055
rdax ramp, 1.0 ;add to ramp value
and 0xbfffff ;allow for rollover (bypasses saturation limiting)
wrax ramp, 1.0 ;write back to ramp register, keep acc
sof 1.0, -0.25 ;subtract 0.25 to center rampwave about 0
maxx reg0, 0 ;get absolute value (make triangle wave from 0 to 0.25)
sof 1.0, -0.125 ;subtract 0.125 to make triangle wave go -0.125 to +0.125
sof .00015, 0 ;scale to filter
rdax tri, 0.9999 ;filter triangle waveform so that pitch bend does not get too great at high rates
wrax tri, 0 ;write triangle wave to register, clear accumulator

kypo
Posts: 17
Joined: Thu Feb 16, 2017 1:49 am
Location: Slovakia

Post by kypo » Tue May 02, 2017 7:28 am

I can try it but I don't know what a part source code relpace with this code.
Still, I do not understand why it does not work for me when for others works .
Here is my hex file (generated by SpinAsm) maybe someone can check it.
http://www.kypo.eu/rom_fla_rev.hex

frank
Posts: 991
Joined: Wed Oct 19, 2005 12:26 pm
Contact:

Post by frank » Tue May 02, 2017 8:46 am

We also need to see the schematic, board layout, etc.
Frank Thomson
Experimental Noize

Digital Larry
Posts: 279
Joined: Mon Nov 12, 2012 12:12 pm
Contact:

Post by Digital Larry » Wed May 03, 2017 12:21 am

kypo wrote:I can try it but I don't know what a part source code relpace with this code.
This is just a copy of the LFO section of that code. I'm not suggesting you replace anything. It works fine for me.

kypo
Posts: 17
Joined: Thu Feb 16, 2017 1:49 am
Location: Slovakia

Post by kypo » Wed May 03, 2017 1:16 am

frank wrote:We also need to see the schematic, board layout, etc.
Schematic is exactly the same as in datasheet. As I wrote higher every all other progs working ok also from external 24LC32 eeprom also internal progs including internal flanger. ( I have tried GA_Demo set, M16-24 set)
I would like to build my own set with small modifications.

kypo
Posts: 17
Joined: Thu Feb 16, 2017 1:49 am
Location: Slovakia

Post by kypo » Wed May 03, 2017 1:27 am

Digital Larry wrote:
kypo wrote:I can try it but I don't know what a part source code relpace with this code.
This is just a copy of the LFO section of that code. I'm not suggesting you replace anything. It works fine for me.
I've reviewed this part of the code and it's exactly the same, so I can not understand where the error might be.

ice-nine
Posts: 125
Joined: Thu May 24, 2012 9:03 am
Contact:

Post by ice-nine » Wed May 03, 2017 2:43 am

kypo wrote:
Digital Larry wrote:
kypo wrote:I can try it but I don't know what a part source code relpace with this code.
This is just a copy of the LFO section of that code. I'm not suggesting you replace anything. It works fine for me.
I've reviewed this part of the code and it's exactly the same, so I can not understand where the error might be.
I don't think digital Larry suggested an error in the code at all he just pointed out how the triangle waveform is made. (within that code snippet).
When you mention 'sweep'do you refer to rate or depth of flange or more like feedback/regen, what exactly are you referring too as this effect has a limited control set, yes it flanges, with more info we may be able to help better.
www.stanleyfx.co.uk
"It's fairly straight forward, if you want to start it press start, you can work out the rest of the controls yourself."

Post Reply