Spin Semiconductor Forum Index Spin Semiconductor
Support forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

rom_fla_rev.spn not functioning
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Spin Semiconductor Forum Index -> FV-1 software questions
View previous topic :: View next topic  
Author Message
kypo



Joined: 16 Feb 2017
Posts: 17
Location: Slovakia

PostPosted: Thu Apr 06, 2017 2:55 am    Post subject: rom_fla_rev.spn not functioning Reply with quote

rom_fla_rev.spn from Free DSP programs not functionin - no sweep.
What's wrong?
Back to top
View user's profile Send private message
kypo



Joined: 16 Feb 2017
Posts: 17
Location: Slovakia

PostPosted: Wed Apr 12, 2017 3:41 am    Post subject: Reply with quote

Nobody knows what is bad there?
Back to top
View user's profile Send private message
kypo



Joined: 16 Feb 2017
Posts: 17
Location: Slovakia

PostPosted: Thu Apr 27, 2017 11:26 pm    Post subject: Reply with quote

Nobody? Frank,please, can you look at it?
Back to top
View user's profile Send private message
frank



Joined: 19 Oct 2005
Posts: 968

PostPosted: Fri Apr 28, 2017 3:38 pm    Post subject: Reply with quote

Downloaded from site, loaded into my dev board and it works fine.
_________________
Frank Thomson
Experimental Noize
Back to top
View user's profile Send private message Visit poster's website
kypo



Joined: 16 Feb 2017
Posts: 17
Location: Slovakia

PostPosted: Sat Apr 29, 2017 3:12 am    Post subject: Reply with quote

It is mysterious. I make it again just now: download from site, assembly in SpinAsm, programming in PonyProg to 24LC32 and doesn't work. In two boards. Reverb is working but flanger not, no sweep. Other progs working OK.
Back to top
View user's profile Send private message
frank



Joined: 19 Oct 2005
Posts: 968

PostPosted: Sat Apr 29, 2017 9:50 am    Post subject: Reply with quote

All I can suggest then is you check your board and make sure the POTs are working properly.
_________________
Frank Thomson
Experimental Noize
Back to top
View user's profile Send private message Visit poster's website
ice-nine



Joined: 24 May 2012
Posts: 122

PostPosted: Sat Apr 29, 2017 11:03 am    Post subject: Reply with quote

I have just put this into a pedal and it is working as it should regarding how it is coded, prehaps it would be of benefit if you could elaborate on what it isn't doing that you are expecting it to do.
_________________
www.stanleyfx.co.uk
"It's fairly straight forward, if you want to start it press start, you can work out the rest of the controls yourself."
Back to top
View user's profile Send private message Visit poster's website
kypo



Joined: 16 Feb 2017
Posts: 17
Location: Slovakia

PostPosted: Sat Apr 29, 2017 11:04 pm    Post subject: Reply with quote

I test it on two boards. Others progs are working there, all pots working. On flanger (rom_fla_rev.spn downloaded from site)) working Pot0 (Reverb level) also Pot2 (Efect level) but Pot1 not working , flanger is not sweeping I think LFO not working. Internal Flanger works fine.
Back to top
View user's profile Send private message
Digital Larry



Joined: 12 Nov 2012
Posts: 272

PostPosted: Sun Apr 30, 2017 7:58 am    Post subject: Reply with quote

I tried it on my Erica Synths Black Hole and it works fine. I hadn't looked too closely at this one before, but the triangle waveform is generated "in software" rather than using a built in ramp. It's really baffling that it doesn't work for you.

DL

========================================

;--------------------------------------------------------
; flange rate from pot 1
; as adder value to ramp
; gen, filtered at 0.3Hz:
;--------------------------------------------------------
rdax pot1, 1.0 ;read pot1
mulx pot1 ;square value, range = 0 to 1
sof 0.05, 0.005 ;scale to range of 0.005 to 0.55
sof .001, 0 ;scale further to 0.00005 to 0.0055
rdax ramp, 1.0 ;add to ramp value
and 0xbfffff ;allow for rollover (bypasses saturation limiting)
wrax ramp, 1.0 ;write back to ramp register, keep acc
sof 1.0, -0.25 ;subtract 0.25 to center rampwave about 0
maxx reg0, 0 ;get absolute value (make triangle wave from 0 to 0.25)
sof 1.0, -0.125 ;subtract 0.125 to make triangle wave go -0.125 to +0.125
sof .00015, 0 ;scale to filter
rdax tri, 0.9999 ;filter triangle waveform so that pitch bend does not get too great at high rates
wrax tri, 0 ;write triangle wave to register, clear accumulator
Back to top
View user's profile Send private message Visit poster's website
kypo



Joined: 16 Feb 2017
Posts: 17
Location: Slovakia

PostPosted: Tue May 02, 2017 6:28 am    Post subject: Reply with quote

I can try it but I don't know what a part source code relpace with this code.
Still, I do not understand why it does not work for me when for others works .
Here is my hex file (generated by SpinAsm) maybe someone can check it.
http://www.kypo.eu/rom_fla_rev.hex
Back to top
View user's profile Send private message
frank



Joined: 19 Oct 2005
Posts: 968

PostPosted: Tue May 02, 2017 7:46 am    Post subject: Reply with quote

We also need to see the schematic, board layout, etc.
_________________
Frank Thomson
Experimental Noize
Back to top
View user's profile Send private message Visit poster's website
Digital Larry



Joined: 12 Nov 2012
Posts: 272

PostPosted: Tue May 02, 2017 11:21 pm    Post subject: Reply with quote

kypo wrote:
I can try it but I don't know what a part source code relpace with this code.


This is just a copy of the LFO section of that code. I'm not suggesting you replace anything. It works fine for me.
Back to top
View user's profile Send private message Visit poster's website
kypo



Joined: 16 Feb 2017
Posts: 17
Location: Slovakia

PostPosted: Wed May 03, 2017 12:16 am    Post subject: Reply with quote

frank wrote:
We also need to see the schematic, board layout, etc.


Schematic is exactly the same as in datasheet. As I wrote higher every all other progs working ok also from external 24LC32 eeprom also internal progs including internal flanger. ( I have tried GA_Demo set, M16-24 set)
I would like to build my own set with small modifications.
Back to top
View user's profile Send private message
kypo



Joined: 16 Feb 2017
Posts: 17
Location: Slovakia

PostPosted: Wed May 03, 2017 12:27 am    Post subject: Reply with quote

Digital Larry wrote:
kypo wrote:
I can try it but I don't know what a part source code relpace with this code.


This is just a copy of the LFO section of that code. I'm not suggesting you replace anything. It works fine for me.


I've reviewed this part of the code and it's exactly the same, so I can not understand where the error might be.
Back to top
View user's profile Send private message
ice-nine



Joined: 24 May 2012
Posts: 122

PostPosted: Wed May 03, 2017 1:43 am    Post subject: Reply with quote

kypo wrote:
Digital Larry wrote:
kypo wrote:
I can try it but I don't know what a part source code relpace with this code.


This is just a copy of the LFO section of that code. I'm not suggesting you replace anything. It works fine for me.


I've reviewed this part of the code and it's exactly the same, so I can not understand where the error might be.


I don't think digital Larry suggested an error in the code at all he just pointed out how the triangle waveform is made. (within that code snippet).
When you mention 'sweep'do you refer to rate or depth of flange or more like feedback/regen, what exactly are you referring too as this effect has a limited control set, yes it flanges, with more info we may be able to help better.
_________________
www.stanleyfx.co.uk
"It's fairly straight forward, if you want to start it press start, you can work out the rest of the controls yourself."
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    Spin Semiconductor Forum Index -> FV-1 software questions All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group